How to import fixtures into D-PRO when no Internet connection is available

Question: How do I manually import fixture definitions from the online fixture editor into D-PRO, when the D-PRO computer does not have internet connectivity?

Currently, the only way to import fixtures into D-PRO is via the Patch Window, and this requires an internet connection (as it reads its data directly from the online fixture library).

A simple workaround is:

  • Install the D-PRO demo version on another computer with Internet connectivity.
  • Import the required fixtures into the demo (via the Patch Window)
  • Copy the Fixtures.dsf database file from the demo installation onto your real D-PRO installation.

The Fixtures.dsf file is a single database file that contains the entire D-PRO fixture library on that computer. It is located here:

OS X

  • Macintosh HD:/Library/Application Support/ENTTEC/D-Pro/Fixtures.dsf

Windows (32 bit)

  • C:/Program Files/ENTTEC/D-Pro (full version)/Fixtures.dsf
  • C:/Program Files/ENTTEC/D-Pro (2U version)/Fixtures.dsf

Windows (64 bit)

  • C:/Program Files (x86)/ENTTEC/D-Pro (full version)/Fixtures.dsf
  • C:/Program Files (x86)/ENTTEC/D-Pro (2U version)/Fixtures.dsf

How to transfer Show Buddy data to a new computer

If you have purchased a new computer and need to move Show Buddy to that computer, this is the process:

  • Install DMXIS & Show Buddy on the new computer.
  • Copy over all your DMXIS data as described here
  • Backup Show Buddy on the old computer (File>Backup, creates a .dbb backup file)
  • Restore the backup ( .dbb file) on your new computer (using File>Restore)
  • Copy the Show Buddy media folder (everything under the Media Files folder) to the new computer. (This article tells you how to locate the Media Files folder)

Check out the Media Storage & Backup Strategy section of the Show Buddy manual for more info.

What equipment do I need for the MIDI Output feature of Show Buddy?

The MIDI Out feature in Show Buddy is primarily intended for controlling hardware FX (like the Roland GT-10 or TC Helicon VoiceLive examples shown in the 1.1.0 release video).

For this, you (obviously) need some external equipment that can be controlled via MIDI commands. Some equipment supports MIDI directly via USB, so all you need to do is install the appropriate drivers and plug the equipment into a spare USB port.

In other cases, where the equipment does not support MIDI over USB, you will need a separate USB-MIDI interface for your computer like this one. Your external equipment would then plug into the MIDI interface.

Show Buddy can also send MIDI to other programs running on the same computer, via a MIDI loopback driver (such as LoopBe on Windows or the standard IAC MIDI driver in OS X). This would let you, for example, synchronise video playback on a VJ program like Resolume with Show Buddy – assuming your computer is powerful enough to run both Show Buddy and the VJ program simultaneously.

Show Buddy Export to MIDI feature doesn’t work with simultaneous cues

Problem

You create a lightshow in Show Buddy which triggers multiple masked presets simultaneously, to build up full looks. When you export this lightshow to a MIDI file and import it into your MIDI sequencer, some of the simultaneous presets do not trigger correctly in the MIDI plugin.

Solution

Try increasing the “Minimum gap between cues” value in the Show Buddy Preferences window, and re-export your MIDI file.

Show Buddy can trigger multiple presets across multiple banks simultaneously without any problems. But this is not possible in the VST/AU plug-in, due to a limitation in MIDI – if the plugin receives 3 notes on ch 15 (bank changes) and 3 notes on ch 16 (preset changes) simultaneously, it has no way of telling which bank change belongs to which preset. Bank/preset changes in a MIDI track must be staggered by a few milliseconds to get round this problem.

The Show Buddy export function will stagger simultaneous bank/preset changes automatically for you, but you may need to play with the “Minimum gap between cues” value to find a reliable setting which works with your particular host & setup.

How Show Buddy manages its data and audio files

Show Buddy stores all your track, lightshow and show information in a single database file. As you create and edit your tracks & shows, Show Buddy automatically and silently saves your changes to the database – there is no File Open or Save option as is found in document based programs.

You can create backups of the current database from the File > Backup database menu option. This will archive the database in a .dbb file. It’s a good idea to backup your database regularly while you are editing, and before each live gig (so you can always recover to a known point should something go wrong).

To restore from a backup, select the File > Restore from backup… menu option and choose a .dbb backup file.

Note that your actual audio tracks (e.g. wav and mp3 files) are NOT saved & restored as part of this procedure. When you drag an audio file into Show Buddy, a copy of that file is made in the Show Buddy media folder. You should separately backup this media folder on a regular basis:

  • Windows XP: C:/Documents and Settings/All Users/Application Data/Show Buddy
  • Windows Vista/7/8: C:\ProgramData\Show Buddy\Media Files
  • OS X: /Library/Application Support/db audioware/Show Buddy/Media Files

In Windows XP, you may also need to enable hidden folders:

  • In Windows Explorer menu, choose Tools > Folder Options…
  • In View tab, click Show hidden files and folders” then Apply
  • Click Apply to All Folders

You should also backup your DMXIS configuration and banks/presets as described here.

Using click tracks with Show Buddy

You want Show Buddy to feed click tracks to your drummer. But you need to use full songs to design your lightshows first. What’s the easiest way to manage this?

Use ‘dual-mono’ audio files

The simplest option is to use audio files containing the click track in the left channel, and a mono mix of your song in the right channel. Then, you can hear the music in Show Buddy (for designing lightshows) and at concert time you can feed the left channel only to the drummers headphones, and mute the right channel.

Replace mixes with click tracks by drag & drop

What if you need to output a stereo click track, or hear your full stereo mix while designing your lightshows? Show Buddy only supports one stereo output for each track, so you can’t load a stereo click and a stereo mix at the same time. However…

With the 1.1.0 release, it’s easy to overwrite old tracks with new tracks. This lets you upgrade your show with new mixes, without losing your lightshows. But with a little clever file management on your part, it can also switch Show Buddy between full mixes and click tracks.

Let’s assume you keep your audio in a Media folder on your desktop. First, create two identical folder structures – one containing your mixes, and another containing your click tracks…

  • Create folders called Media/FullMixes and Media/ClickTracks
  • Create identical category folders in both (FullMixes/Rock, FullMixes/Ballads etc)
  • Copy your full mixes to e.g. FullMixes/Rock/MySongA.mp3
  • Copy your click track to e.g. ClickTracks/Rock/MySongA.mp3

The important thing is that we end up with two identical file structures, one containing mixes and another containing click tracks.

Now, you can drag an audio file into Show Buddy from the FullMixes folder to design your lightshow. Later, you can drag in the file with the same name from the ClickTracks folder, to replace the mix with your click track.

Manually copy your click track files

The above technique might become tedious if you have a large number of tracks. A third option is to manually overwrite the audio files stored in Show Buddy’s Media Files folder as necessary. (See this article for an explanation of the Media Files folder). This will work fine as long as the replacement audio files have identical length – which you need anyway if your click tracks are to sync with the lightshow!

Using masked presets & momentary cues in Show Buddy

Say you have a couple of blinders on DMX channels 23 & 24. You want to independently fire this blinder on & off within Show Buddy, without affecting the settings of the other lights.

  • In the DMXIS window, create a new bank called Blinders
  • Run the Channel Masks > Disable all channels macro. All channels faders appear grayed out.
  • Drag ONLY the channel 23 & 24 faders to maximum. This will automatically enable them.

  • Save this as preset Full in the Blinders bank.
  • Drag the channels 23 & 24 faders to minimum. Save this as preset Off in the Blinders bank.

Now you can drag the Full preset onto your song in Show Buddy. A new momentary cue appears at the bottom of the waveform.

Position it and change the length as necessary. At the start of the cue, Show Buddy loads the Full preset, and at the end of the cue it loads the Off preset – all without affecting your other lights.

The important preset here is the Off preset. The presence of this special preset makes all other cues in that bank momentary cues. (Note that the name is case sensitive – it must be “Off“, not “OFF“).

You can add further cues to the bank as needed – for example a preset called “Half” which sets faders 23 & 24 to 50% level.